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Preface

This User’s Guide provides instruction on working within the ULTRA Desktop 
application. When possible, supporting reference information is provided as background 
information to help you complete your work. 

• The Installation chapter guides you though installing and setting up ULTRA Desk-
top for the first time. 

• The Document Manager Basics chapter provides reference information on ULTRA 
Desktop processes and terminology. 

• The Using Document Manager chapter provides task-based information on using 
features in Document Manager. 

• The Using Image Manager chapter provides task-based information on using the 
features within Image Manager.

• The Other Tools and ULTRA Desktop chapter provides a few simple scenarios for 
using ULTRA Desktop with other applications such as TRADOS and Adobe Pho-
toshop.

WHAT IS ULTRA DESKTOP?

eTranslate’s ULTRA Desktop is the professional standard for localization resources. Using 
eTranslate’s GlobalLink to manage content and the ULTRA server to manage all projects. 
ULTRA Desktop provides easy access to content and important reference information. 

The ULTRA Desktop application has two tools: Document Manager and Image Manager.

Document Manager

Document Manager allows you to receive and send project tasks and content from your 
desktop during the localization process. This interface to the ULTRA project management 
system provides detailed information on each task within the localization workflow; this 
includes the file name, the project name, the word count, the type of file, and the due date. 
It is the default tool used in the ULTRA Desktop application. 
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PREFACE

What is ULTRA Desktop?
Chapter
Image Manager

Graphics translation is facilitated by Image Manager. Image Manager provides a single 
tool for viewing, transcribing, and translating graphics. It is accessible from Document 
Manager.

See also:
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PREFACE

Who uses ULTRA Desktop?
WHO USES ULTRA DESKTOP?

Table 1: ULTRA Desktop roles lists the roles that use ULTRA Desktop. Some features may 
not be accessible by all users. 

Table 1: ULTRA Desktop roles

Role ULTRA Desktop actions Other tools used

Localization 

Assessor (LA)

Responsible for the classification 

of non-graphics files.

TRADOS

Translator Get/Submit documents from 

ULTRA for initial translation.

TRADOS

Editor Get/Submit documents from 

ULTRA for post-translation editing.

TRADOS

Proofreader Get/Submit documents from 

ULTRA for post-editing 

proofreading.

TRADOS

Localization 

Engineer

Get/Submit documents from 

ULTRA for localization.

LE scripts and macros

Graphics Assessor 

(GA)

Responsible for the classification 

of graphics files. 

Image Manager and 

image rendering tools 

such as Photoshop

Graphics Engineer Get/Submit project documents 

containing art, identify localizable 

graphics and their translatable 

text, transcribe text, and render 

graphics.

Image Manager and 

other image rendering 

tools

Linguistic QA Get/Submit documents during 

final stages of project to review 

target sites for consistency and 

linguistic changes.

QA tools

Functional QA Get/Submit documents during 

final stages of project to set up 

and test target sites.

QA tools
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PREFACE

The eTranslate system
Chapter
THE ETRANSLATE SYSTEM

As a member of the eTranslate localization team, your work is streamlined by eTranslate’s 
sophisticated, integrated system designed to make your job easier.

GlobalLink, ULTRA server, and ULTRA Desktop facilitate the localization process. Each of 
these components works with the others to keep the workflow moving smoothly.

ULTRA Desktop serves as your connection to the ULTRA server, which manages the 
localization workflow. You can use ULTRA Desktop to log into the ULTRA server or to 
work on task content locally. ULTRA Desktop searches the ULTRA server and displays 
only the documents which are assigned to you. Once you've finished working on a 
document, ULTRA Desktop makes it simple to send the finished product back to the 
server. In addition, you'll be able to style guides, notes, glossaries, and other reference 
content for a project using ULTRA Desktop.

GlobalLink

GlobalLink is used by clients to send a localization project to the ULTRA server, beginning 
the workflow process.

ULTRA server

ULTRA manages localization projects, assigning the various files to the appropriate 
locations and personnel, processing documents, and tracking every part of the 
localization process.

ULTRA Desktop

ULTRA Desktop serves as your connection to the ULTRA server, allowing you to Get and 
Submit task from any location.
6 ULTRA Desktop User’s Guide
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What’s new in ULTRA Desktop 3.0?
WHAT’S NEW IN ULTRA DESKTOP 3.0?

The following features are new to this release of ULTRA Desktop.

TRADOS integration. Export translation memory for use with TRADOS tool.

Classification. Classifying source documents: QA Reference, Resource Reference, 
Graphics Reference, Localizable, Translatable, Out Of Source, and Hold.

Content. A pane displaying task content such as GIFS and JPEGs.

Task notes. Comments from a task rejection which are displayed from a previous step in 
the workflow.

Image Manager. A tool to annotate and transcribe images for translation and translate.

Reference content. A pane to display reference content such as glossaries and style 
guides.

History pane. Lists the manual and automated steps of the workflow that the task has 
passed through, and the results of each step.
ULTRA Desktop User’s Guide 7
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What’s new in ULTRA Desktop 3.0?
Chapter
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1
Installation

Before you begin, verify that you have the minimum requirements for installation.

This chapter describes the following topics:

• Installation and connection requirements

• Installing ULTRA Desktop
ULTRA Desktop User’s Guide 9



INSTALLATION

Installation and connection requirements
Chapter  1
INSTALLATION AND CONNECTION REQUIREMENTS

To install and run ULTRA Desktop successfully you must meet the minimum system and 
connection requirements.

Table 2: System and connection requirements lists the minimum requirements that eTranslate 
recommends for a successful installation of ULTRA Desktop. 

Table 2: System and connection requirements

Minimum requirements Recommended requirements

Pentium 100 Mhz or equivalent 

processor.

Pentium II 233 Mhz processor.

64 MB RAM 128 MB RAM

Microsoft Windows 98, 2000, ME, or Microsoft Windows NT version 

4.0.

28 Kbps modem or faster. 56 Kbps modem.

Must be able to connect to ULTRA through your network or through 

the Internet.
10 ULTRA Desktop User’s Guide



INSTALLATION

Installing ULTRA Desktop
INSTALLING ULTRA DESKTOP

Follow these steps to install ULTRA Desktop.

1. On your ULTRA Desktop CD-ROM, double-click the Install.exe file to begin your 
installation.

The Introduction screen appears.

2. Click Next to continue.

The License Agreement screen appears.

3. If you accept the terms of the License Agreement, Click Accept, then Next to 
continue with the installation.

The Choose Shortcut screen appears.

4. Select the location where you want to create product icons. This is how you will 
launch ULTRA Desktop once it has been installed.
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INSTALLATION

Installing ULTRA Desktop
Chapter  1
5. Click Next.

The Document Folder screen appears.

6. Select the document folder. This is the location on your local drive where tasks 
that you download from the ULTRA server will be placed.

7. Click Next.

The Pre-Installation Summary screen appears. This screen provides the details of 
the installation.

8. Click Install.

The Install Progress screen appears. If your installation was successful, the 
Install Complete screen appears.

9. Click Done to quit the installer.
12 ULTRA Desktop User’s Guide



2
Document Manager Basics

ULTRA Desktop is a localization toolkit that allows you to receive and send tasks and task 
content from your desktop during the localization process. This interface to the ULTRA 
project management system provides detailed information on each task within the 
localization workflow, such as the name of the task, the project name, the word count, the 
type of file, and the due date. 

A task in ULTRA Desktop is a step in the workflow of a file, or a document, that has been 
sent to you from the ULTRA server. What you do with that task depends on your role. If 
you are a translator, for example, then your role may be to localize the source content into 
the target language. If you are an assessor, than your role may be to assess the task that 
needs to be localized, and determine if it is Translatable, or Non-Translatable. 

The Image Manager tool within ULTRA Desktop is used by Graphics Engineers and 
translators to localize image content. 

This chapter describes the basic features of Document Manager.

The following topics are covered:

• Document Manager main window

• Document Manager panes

• Document Manager toolbar

• Understanding the Tasks pane

• Understanding the Reference Content pane

• Understanding the Target Classification pane

• Understanding the Content pane
ULTRA Desktop User’s Guide 13



DOCUMENT MANAGER BASICS

Understanding the Tasks pane
Chapter  2
DOCUMENT MANAGER MAIN WINDOW

The Document Manager main window is the central access point in the ULTRA Desktop 
document management process. Figure 1: Document Manager main window shows the main 
features.

Figure 1: Document Manager main window

Application title bar. Displays the application you are working in, the tool (Document 
Manager or Image Manager), the username, and the ULTRA server you connect to.

Toolbar. Buttons used to access Document Manager’s features.

eTranslate logo. Click this button to log in to the ULTRA server. It also spins when 
communicating with the ULTRA Server and is indented once you are connected.

Menus. Allow access to all of ULTRA Desktop’s features.

View. An area displaying data about your tasks.

Column headers. Specifies the information displayed in each column.

Filters. A field or drop down menu used to specify search criteria for that column.

Column fields. Displays information related to each task. For example, the Project 
column field displays the name of the project this task belongs to.

Menus

View

Connect 

eTranslate logo Toolbar

Column 

headers

Column fields

Filters

Application title bar
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DOCUMENT MANAGER BASICS

Understanding the Tasks pane
DOCUMENT MANAGER PANES

A pane in Document Manager displays detailed information about your tasks.

Upon launching ULTRA Desktop the default display is the Task pane. For a detailed 
description of each pane see Table 3: Document Manager panes.

Table 3: Document Manager panes

Panes Definition

Tasks The Tasks pane is the default display. It displays columns 

with information related to each task assigned to you.

History Displays the steps that a particular task has followed. You 

must have a task selected in the Task pane to display its 

history and be connected to the ULTRA server.

Reference 

Content

Displays any supporting materials that have been 

submitted for a project. This can include a project style 

sheet, a glossary, or instructions. 

Target 

Classification

s

Allows you to classify a task’s particular targets as: QA 

Reference, Resource Reference, Graphics Reference, 

Localizable, Translatable, or Out Of Scope. 

Content Displays the images in GIF and JPEG files once they have 

been downloaded to your desktop.
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DOCUMENT MANAGER BASICS

Understanding the Tasks pane
Chapter  2
DOCUMENT MANAGER TOOLBAR

The buttons that appear in the Document Manager toolbar are: Find Tasks, Refresh Tasks 
List, Get, Submit, Copy Selected Tasks, Reject Selected Tasks, Delete Selected Tasks, 
and the eTranslate logo. Table 4: Document Manager buttons details each button and its 
definition. 

Table 4: Document Manager buttons

Icon 

Button 

Name Definition Menu option

Find Tasks Searches locally 

on selected 

filters.

File>Find Tasks.

Refresh 

Task List

Refreshes the 

Tasks pane 

from the ULTRA 

server.

None.

Get Gets tasks from 

ULTRA to the 

desktop.

File>Get.

Submit Submits tasks 

to ULTRA from 

the desktop.

File>Submit.

Copy 

Selected 

Tasks

Copies a task to 

the desktop 

without Getting 

it from ULTRA.

File>Copy Task.

Reject 

Selected 

Tasks

Rejects tasks 

that have been 

received.

File>Reject Tasks.

Delete 

Selected 

Tasks

Removes tasks 

from the Task 

pane and your 

local drive.

Edit>Delete Selected 

Tasks.

eTranslate 

logo

Launches 

connection 

dialog. Spins 

when 

connecting to 

the ULTRA 

server. Also 

used to 

disconnect.

File>Connect and

File>Disconnect.
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DOCUMENT MANAGER BASICS

Understanding the Tasks pane
UNDERSTANDING THE TASKS PANE

The Tasks pane displays a table with tasks available to you. When you log into the 
ULTRA server, all tasks that have been assigned to you on the ULTRA server are 
displayed. It also displays work that you have obtained and have on your local drive. 
Tasks that are available for you on your desktop, whether you received or copied them 
display a white document  icon.

Detailed information related to each task is also available. The Tasks pane has columns 
with Project name, Source Path, Classification, Task name, Language, State, Words, 
Domain of expertise, Type, Source Type, ID, Due Date, and Submission ID. 

Columns

The columns in the Tasks pane display detailed information related to each task row. Each 
column can be moved within the table, and each column can be sorted up or down 
alphabetically or numerically.

TO RE-ORDER THE COLUMNS

1. Click in the column header of the column you want to move.

Task column
Column header
ULTRA Desktop User’s Guide 17



DOCUMENT MANAGER BASICS

Understanding the Tasks pane
Chapter  2
2. Drag the column horizontally to the desired position. 

TO SORT COLUMNS ALPHABETICALLY OR NUMERICALLY

1. Click near the right edge of the column header.

An arrow appears indicating a sort ascending or descending.

2. Click in the column header more than once to change the direction of the sorting.

THE PROJECT COLUMN

The Project column lists the project name for each task. All tasks sent to you from ULTRA 
are part of a project. This column can be sorted alphabetically.

You may be working on many projects simultaneously. Thus the Project column may be 
crowded with tasks for many projects. ULTRA Desktop lets you “filter” on the Project 
column to display all tasks within a certain project only.

Click and drag in any horizontal direction

Arrow indicates ascending sort

Arrow indicates a 

descending sort

Project column

Project name
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DOCUMENT MANAGER BASICS

Understanding the Tasks pane
THE SOURCE PATH COLUMN

The Source Path column shows the file path of the task as it was submitted to ULTRA. 
This column can be sorted alphabetically.

THE CLASSIF ICATION COLUMN

The Classification column displays the current classification of the task. Depending upon 
your role, you may be able to reclassify tasks. 

For example, an Assessor reclassifies tasks and determines how they will proceed through 
the workflow. See Table 5: Classification Definitions for a listing of what each classification 
designation means.

Table 5: Classification Definitions

Classification Definition

QA Reference The person classifying the tasks finds the 

document to be useful in the Functional QA 

localization process, but not translatable. 

Resource Reference The person classifying the tasks finds the 

document to be useful to people involved in the 

localization process, but not translatable. Typical 

content is useful for translating, editing, and 

proofreading of a task.

Graphics Reference The person classifying the tasks finds the 

document to be useful in the graphics localization 

process, but not translatable. 

Non-Translatable A document is not translatable. If a task is 

classified as non-translatable it will not go 

through the translate, edit, and proof workflow. 

It goes directly to Functional QA.

LE Reference A document that is useful to the Language 

Engineer as Reference Content.

Task name

Classification 

designation
ULTRA Desktop User’s Guide 19
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Understanding the Tasks pane
Chapter  2
THE STATE COLUMN

The State column displays the current status of the tasks displayed in the Tasks pane. For 
example, a task may show a Ready status because it is ready for you to Get from ULTRA. 
Table 6: State definitions lists the states and definitions of a task. 

THE TASKS  COLUMN

The Tasks column indicates where in the workflow each task is. Depending upon your 
role, you may see one or all of these steps. For example, if your role is a translator, you 
may only see tasks with the Translate task. See Table 7: Tasks definitions/workflow step for a 
list of possible task designations and definitions.

Instructions A document that contains instructions associated 

with a project and sent through the workflow as 

Reference Content.

Style Guide A document that contains a style guide 

associated with a project and should be sent 

through the workflow as Reference Content.

Glossary A document that contains a glossary for the 

project and should be sent through the workflow 

as Reference Content.

Translatable The task needs to go through the complete 

localization workflow.

Out Of Scope Tasks deemed as not deliverable.

Hold The person classifying the tasks doesn’t want the 

task to move on in the localization process. 

Table 6: State definitions

State Definition

Ready The task is ready to be downloaded from ULTRA to your 

desktop.

Rejected The task was downloaded, you rejected it, and it was 

submitted back to ULTRA.

Submitted The task was sent back to ULTRA after being completed.

Username The task was downloaded and is currently owned by this 

user.

Table 5: Classification Definitions

Classification Definition
20 ULTRA Desktop User’s Guide
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Understanding the Tasks pane
Table 7: Tasks definitions/workflow step

Tasks Definition

Assessment 

(GA)

All new graphics documents are examined and classified by 

the Graphics Assessor. 

Assessment 

(LA)

All new non-graphics documents are examined and 

classified by a Localization Assessor.

Assessment 

Prep (LA)

The localization engineer must prepare the document.

Classify (LA) Language engineer will classify the task.

Clean (LE) If a text document fails to be converted from TRADOS-

compatible RTF format back to its original (native) file 

format during the automated Convert to Native Format 

task, the Clean (LE) task will be used to permit a 

Localization Engineer to manually convert the file. 

Edit Documents which have completed the Translate task 

typically proceed to this task, in which an editor makes any 

necessary changes to the translator’s work. 

Fix (LE) Documents that generate errors or are rejected in ways not 

covered by workflow conditions will be assigned this task, 

which enables a Localization Engineer to make the 

necessary changes required to return documents to the 

normal workflow. 

Fix from FQA 

(LE)

After project documents have completed nearly all of the 

localization process, it is necessary to ensure that target 

documents still work properly. For example, if a web site is 

being localized, all links and images will require checking. 

The Functional QA (FQA) task is the point at which such 

testing is performed and changes, if any, are made by the 

project’s Functional QA. 

Functional 

QA (Non-

Translatable)

Some documents submitted to a project may not contain 

any localizable text but are still necessary for the delivered 

target documents to work properly; for example, a 

Javascript file which is necessary for the function of a web 

site. This type of document will not have any of its content 

localized but will still be delivered with other target 

documents. When this task is enabled in a workflow, 

documents classified as Non-Translatable will 

immediately be directed to the Deliver task. 

Language 

Prep (LE)

This task is similar to the Prep (LE) task, but it is always 

performed on documents in the target workflow. 

Linguistic QA Grammatical and cultural QA of translated content.
ULTRA Desktop User’s Guide 21
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THE LANGUAGE COLUMN

This Language column displays the source language of the listed task. The value specifies 
two pieces of information: source language and country.

For example, en-AU is the English language as spoken in Australia. en-GB is the English 
language as spoken in Great Britain, and en-US is the English language as spoken in the 
United States. 

Prep (LE) If a text document has technical defects that prevent it 

from proceeding to the next workflow step, a Localization 

Engineer will be assigned to prepare it for the next step. 

Generally, this means the Localization Engineer will 

perform the file conversion by hand.

Proofread Documents which have completed the Edit task typically 

proceed to this task, during which a Proofreader makes any 

necessary changes to the Editor’s work. 

Render (GE) Once a graphics document’s content has been completely 

localized, the Render task is used to assemble the 

completed target graphic from the text/image information 

contained in the GTX file associated with the source 

graphic. The product of this task is the completed target 

document image, in the format used by the original image. 

Review Clients may want to inspect and/or make changes to 

project documents after the Translate, Edit, and/or Proof 

tasks. The Review task provides this ability; when it is 

enabled in the workflow, users with the Reviewer role may 

use ULTRA Desktop to access documents and make 

changes as needed. 

Transcribe 

(GE)

Using Image Manager in ULTRA Desktop, the Graphics 

Engineer extracts the translatable text from a graphics file 

and saves text and other image data in a GTX file. 

Translate Task is ready to be translated from the source language to 

the target language.

Table 7: Tasks definitions/workflow step

Tasks Definition

Language column

Source language
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Understanding the Tasks pane
THE WORDS  COLUMN

This Words column displays the word count of the task content. 

THE DOMAIN COLUMN

The Domain column displays the area of expertise needed to work on the task. For 
example, the task may require expertise in the area of Accounting and Auditing or the 
task may require just General Knowledge.

THE TYPE COLUMN

The Type column indicates the MIME type of the task’s current content.

THE SOURCE TYPE COLUMN

The Source Type column indicates the MIME type of the task as it was sent from the 
customer. 

Domain column

MIME type

MIME type
ULTRA Desktop User’s Guide 23
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Understanding the Tasks pane
Chapter  2
THE ID COLUMN

The ID column indicates the task ID assigned by the ULTRA server. It is unique to each 
task.

THE SUBMISSION ID  COLUMN

The ID of the GlobalLink submission containing the content of this task.

THE DUE DATE COLUMN

The Due Date column displays the date and time the task is due to be completed.

THE RELATED  CONTENT COLUMN

The Related Content column displays any content that is associated with the selected 
task. For example, once a GIF file has been associated with a GTX file, the GTX task’s ID 
information, or file name is listed.

ID column

Submission 

ID

Related Content column

Associated tasks
24 ULTRA Desktop User’s Guide



DOCUMENT MANAGER BASICS

Understanding the Tasks pane
THE DOCUMENT PATH COLUMN

When you Get a task from the ULTRA server, it’s content is placed on your desktop. To 
access the task content, it helps to be familiar with the directory structure ULTRA Desktop 
uses for file storage. The complete local file path and file name of each document you have 
obtained is easily determined from the information displayed in the Document Path 
column header and the task’s path column field.

The Document Path column header information is combined with the tasks path 
information, you can determine where on your desktop each task is located. In 
Figure 2: Document Path column, for example, the location of one of the tasks listed is: 
C:\UltraDocument\ldobrozensky\muffy@engstage2.etranslate.com\Content\10000\
Desktop News\de-DE\Render (GE)\GLContent\en-US\links.gif.

Figure 2: Document Path column

NOTE: Do not move, rename, or delete any ULTRA Desktop 
folders. Moving or renaming files will prevent ULTRA 
Desktop from locating documents.

The column header displays a path with the following information:

Default document path. This path was chosen during the installation process.

Username and ULTRA server. ULTRA Desktop creates a new folder for every user 
that logs on and places all content in each user’s personal directory.

Content folder. Always called content.

The Task’s path field displays a path with the following information:

Customer code. A unique number generated by the ULTRA server for each customer.

Project name. The name of the task’s project.

Language. The source language of the task.

Workflow step. The step in the workflow of the task.

Task name. The file path of the task as displayed in the Source Path column

Default document path

Username and ULTRA server

Content folder

Customer code

Project name

Language

Workflow step

Task file path

Task’s path 

field

Local user
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Understanding the Tasks pane
UNDERSTANDING THE REFERENCE CONTENT PANE

Working on a task is easier if you have access to project resources, such as style guides, 
submission instructions, glossaries, and other supporting materials. Some reference 
content is associated with a specific task or language within a project, while others are 
applicable to all tasks within a project.

The Reference Content pane displays reference content related to the selected project. The 
following information is available:

Project. The list of projects. Select a project to see the reference content for that project. 

Classification. Indicates the type of the reference content available. 

Language. Indicates the target language of the reference content. 

Source Path. Indicates the name and location of the reference content.

Type. Indicates the MIME type of the reference content. 

File Path. Indicates the location where the reference content has been copied.

Viewing the Reference Content pane

The Reference Content pane allows you easy access to all reference content that is sent 
with each project. If you are working on multiple projects, then the Reference Content 
pane displays all project names and any associated reference content.

TO VIEW THE REFERENCE CONTENT PANE:

1. Connect to the ULTRA server.

2. Click the View menu.

3. Select Show Reference Content.

Copying reference content

You can copy reference content to your desktop.

TO COPY REFERENCE CONTENT

1. In the Reference Content pane, select a project.

2. The reference content available for that project will be listed.
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3. Select the reference content items you want to copy to your desktop.

4. Click the Copy button.

The reference content is copied to a temporary file in your local path.
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Understanding the Tasks pane
UNDERSTANDING THE TARGET CLASSIFICATION PANE

The Target Classification pane allows Assessors to designate tasks for continued flow in 
the workflow. The assessor at this point looks at the tasks and determines by tasks and by 
language whether the tasks is a Glossary, Graphics Reference, Hold, Instructions, LE 
Reference, Non-Translatable, Out Of Scope, QA Reference, Resource Reference, Style 
Guide, or Translatable.

Viewing the Target Classification pane

The Target Classification pane displays a table with the target languages of the selected 
task, as well as the classification for each language.

TO VIEW THE TARGET CLASSIFICATION PANE

1. Select a task in the Task pane.

2. In the View menu, select Show Target Classification.

The Target Classifications pane opens and displays the target languages and 
their classifications.

Reclassifying tasks

If your role is other than the assessor, the Target Classifications pane displays the target 
language and whether the tasks has more than one target language and the action to be 
taken on that language’s content. 

TO RECLASSIFY A TASK

1. Select a Target Language.

2. Click in the classify cell to activate the drop down list of classifications.

3. Select a classification.

Document Manager places an asterisk in the Classification column in the Task 
pane if a there are two different classifications associated with a task.
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Figure 3: Target Classifications - Two Targets, Two Classifications demonstrates how a task can 
have two target languages and have two different classifications. 

Figure 3: Target Classifications - Two Targets, Two Classifications

.

Selected task Asterisk

Two target 

languages and two 

classifications
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UNDERSTANDING THE HISTORY PANE

The History pane displays the steps that a particular tasks has followed. For example, a 
proofreader may wish to see the file as it appeared before the translator submitted it for 
editing. ULTRA Desktop accomplishes this with the History pane. A yellow document 
icon indicates that that task has notes from a previous step in the workflow. 

The History pane displays the following information:

ID. A unique ID number generated by ULTRA that is associated with the task.

Step. Indicates the various steps the tasks has taken.

Status. The result of each step. For example, a document may have been rejected and 
resubmitted to ULTRA.

Result. Indicates the action taken on a task at a particular step in the workflow.

Completed. The Date and time the task was submitted to ULTRA.

Type. The MIME type of the content for that task.

Comment. Displays if a tasks has comments that were submitted.

Viewing a task in the History pane

You can view a task from an earlier step in the workflow process.

TO VIEW A TASK’S HISTORY:

1. Connect to the ULTRA server. 

2. In the Task pane, select a task.

3. From the View menu, select Show History. 

The History pane appears. 

4. Double- click on any of the steps to view the document as it appeared at that point 
in the workflow. 

5. Click a step to see comments if post-it icon  is present.
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UNDERSTANDING THE CONTENT PANE

The Content pane displays GIF and JPEG images once they have been downloaded to 
your desktop. 

Viewing and hiding the Content Pane

Viewing and hiding the Content pane in Document Manager is simple.

TO VIEW THE CONTENT PANE

1. In the View menu, select Show Content.

The Content pane appears.

2. Select a GIF or JPEG task in the Tasks pane that has been downloaded to your 
desktop.

The image should appear in the content pane. 

NOTE: If the image does not appear, verify that you have 
downloaded the tasks from the ULTRA server to your 
desktop.

TO HIDE THE CONTENT PANE

1. Click the View menu.

2. Select Hide Content.
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This chapter describes using the features in ULTRA Desktop Document Manager to work 
on tasks.

Document Manager provides an efficient means of working on various translation 
projects. It’s purpose is to serve as your window into the workflow of handling tasks for 
translation editing, proofreading, and assessing tasks. You can log on to the Internet, 
launch ULTRA Desktop, and begin working on your tasks.

The Get command is the process of retrieving a task that is ready for you to work on from 
the ULTRA server. If your role is a text translator, than the document could be a RTF 
document or a Microsoft Word document. If your role is a graphics engineer, then the 
tasks waiting for you can be an image file. Whatever your role, the ULTRA Desktop 
window is a display that allows you to manage your translation work from your desktop 
back to your project manager.

The Following topics are described in this chapter:

• Logging on

• Logging on as a different user

• Getting tasks

• Opening a task

• Copying tasks

• Submitting tasks

• Deleting tasks

• Searching for tasks

• Rejecting tasks

• Changing a file type

• Exporting Translation Memory (TM)

• Disconnecting from ULTRA
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LOGGING ON

To log on to the ULTRA server with Document Manager you must have your ULTRA 
username, password, and ULTRA server information. After the first use, Name and server 
become your default entries. To change your username or password on ULTRA, you must 
contact your Language Manager.

TO LOG ON TO DOCUMENT MANAGER:

1. Connect to the Internet.

2. Launch the ULTRA Desktop application.

The ULTRA Desktop Document Manager main window appears.

3. Click on the eTranslate logo , or File>Connect.

The ULTRA User window appears.

4. Enter your username and Password in the corresponding fields.

5. Enter the name of the ULTRA server in the server field.

6. Click the Connect button.

The eTranslate logo spins indicating that the application is connecting with the 
ULTRA server.

ULTRA server 

name

ULTRA user’s name

User’s 

password
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LOGGING ON AS A DIFFERENT USER

Multiple users can share a single computer's ULTRA Desktop application, provided that 
each user logs in with their own username and password. Task and documents 
downloaded from ULTRA are saved separately for each username.

TO LOGON AS A DIFFERENT USER:

1. Connect to the Internet.

2. Launch the ULTRA Desktop application.

The ULTRA Desktop Document Manager main window appears.

3. Click on the eTranslate logo , or File>Connect, to get to the log on window.

The ULTRA User window appears.

4. Enter the new username and Password in the corresponding fields.

5. Enter the name of the ULTRA server in the server field.

6. Click the Apply button.

This creates a folder for the new user on the desktop in the document file path. 
Any tasks the new user gets or copies are placed in the document file path with 
the user’s name on the desktop.

7. Click the Connect button.

The eTranslate logo spins indicating that the application is connecting with the 
ULTRA server.

You can choose to open and work on documents you have previously obtained, or to 
connect to the ULTRA server and get new documents. Some actions can be performed 
without going online, while others require that your computer connect to the ULTRA 
server via the Internet.

ULTRA server 

name

User’s name

User’s 

password
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GETTING TASKS

Document Manager’s Tasks pane displays a list of the tasks available to you from the 
ULTRA server. If a task is in the Ready state it is available for you to Get from the ULTRA 
server. Once you Get a task from ULTRA it is no longer available to any other users. The 
Get process downloads a task from the ULTRA server to your desktop. 

TO GET A TASK:

1. Connect to the Internet.

2. Highlight a task, or group of tasks that are in the Ready state.

3. Click the Get button, or File>Get. You can also Get a document by double-
clicking on it in the Task pane.

The State column changes to your user name to indicate that you have checked 
the tasks out from ULTRA.

When a task is available on your desktop, a white document symbol is 
displayed on the task’s line.

Document Manager places the task content in your document file path. The task 
is now available for you on your local machine.

If you are getting a task which you have previously copied or rejected (without deleting), 
you will be given the option of overwriting the copied file with the version on the server. 
Any changes made by you to the copied document will be lost if you choose to overwrite 
it.

NOTE: Once a task’s content is on you local drive, do not move, 
rename or change the file type. ULTRA Desktop will not 
allow you to Submit the completed task back to the 
ULTRA server unless it can find the local document.
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OPENING A TASK

Opening a task that you are ready to work on once you have performed the Get or Copy 
command is a simple process.

TO OPEN A TASK:

1. Select the task in the Task pane.

2. Double-click the task.

This will Get it, if possible.
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COPYING TASKS

If you have tasks in your Task pane that you do not want to Get from ULTRA, you can 
Copy them to your desktop. Copying a task from ULTRA does not change the state of the 
task, it just makes the content available on your desktop. For example, if you want to view 
a task before checking it out from ULTRA, you can Copy it to your desktop. When a task 
is available on your desktop, a white document symbol is displayed on the task’s line, 
but the state does not change.

TO COPY A TASK:

1. Connect to the Internet.

2. Highlight a task, or group of tasks.

3. Click the Copy button, or File>Copy Task.

The location of the copied document can be found by navigating to the default 
folder as listed in the column path header and the document path field. 

If you copy a task to your desktop and you decide that you want to work on the task, you 
must then Get the task from the ULTRA server. 
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SUBMITTING TASKS

Submitting a task to ULTRA is the process of returning a task ULTRA PM so it can move 
to the next step in the workflow. For example, if you have performed the Get action, 
translated the document, and are ready to return it to ULTRA, you must Submit it.

TO SUBMIT A TASK:

1. Connect to the Internet.

2. Highlight the task or tasks in the task window that you are ready to Submit. The 
task State must be your username to submit it.

3. Click the Submit button, or File>Submit.

4. The eTranslate logo spins while connecting and submitting the task.

Once a task has been submitted, if you no longer want it displayed in your Task pane, you 
must delete it. 
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DELETING TASKS

You can delete a task from the Tasks pane. Deleting a task removes the item from the 
Tasks pane display as well as from your local drive. 

NOTE: Deleting a task only removes the item from your Tasks 
pane and desktop. If you Get a task and do not want to 
work on it, you need to reject it, so that ULTRA PM will 
release it and make it available to other users.

The Delete command can be used to remove tasks you copied and want to remove from 
the Tasks pane and your local drive.

TO DELETE A DOCUMENT:

1. Select the item in the Task pane.

2. Click the Delete button.

The deleted task is removed from the Task pane and from your desktop.

Do not delete documents with your username in the State field of the Task pane. If you 
cannot or will not work on a document which you have already obtained from the ULTRA 
server, you must release it. If you delete such a document by mistake, the copy function 
can be used to refresh the deleted document. However, any changes made before deletion 
will be lost. You will be warned before ULTRA Desktop will delete tasks you have 
received.
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SEARCHING FOR TASKS

ULTRA Desktop searches using the filter fields at the top of each column. Depending 
upon the column, you can either enter or select filters to define your search. When a large 
number of tasks are displayed, finding a specific task can be a challenge. You can display 
only the tasks which match specified criteria by using the filters available in each of the 
column headers to narrow your search. 

Figure 4- Filter fields

You can specify search criteria from any combination of fields. For example, selecting 
Translate in the Task pull-down menu, de-DE in the Language pull-down menu, and 
entering “*Instructions*” in the Source Path field refines the display to items with 
“Instructions” somewhere in the path or filename text, awaiting translation into German 
German.

You can select values from or enter information in as many filter fields as necessary. 

Text can be entered or pasted into the Source Path field in order to limit a search to 
document paths or filenames containing the specified text. Some things to keep in mind 
when defining text filters:

• Text searches are case-sensitive, so you must capitalize letters correctly in order to 
receive good results.

• The asterisk (*) must be used as a wildcard character when entering partial val-
ues. For example, entering “*memo*” in the Path field will show all documents 
with the text “memo” anywhere in its path or filename, regardless of what text is 
found before or after. If you do not use wildcards, you must enter the complete 
path or filename in order to get any search results.

TO ENTER TEXT IN THE TEXT FILTER

1. Enter text in the appropriate filter field.

2. Add the asterisk (*) before and after an entry as a wildcard to search for results 
containing that word.

3. Click the Find Tasks button, or File>Find Tasks.

Document Manager displays the results of your search criteria.

TO SELECT CRITERIA FROM A DROP-DOWN LIST

1. Click on the filter for the column that has a filter drop-down list.

Filter fields
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2. Click on the small button at the right side of the field to activate the pull-down 
list.

3. Scroll and click to select an item for the search.

4. Click the Find Tasks button, or File>Find Tasks.

Numerical values can be typed or pasted into the ID or Words fields. The asterisk (*) 
wildcard character may be used in the ID field, but not in the Words field. A search based 
on a specified word count will return only those documents with exactly the word count 
entered in the field.

ENTERING NUMBERS IN THE ID OR WORD COUNT FILTER

1. Enter numbers in the ID, Word Count, or Batch ID filter fields.

2. Click the Find Tasks button, or File>Find Tasks.

ULTRA Desktop only returns results with identical matches to the numbers you 
entered.

Restoring all tasks to the Task pane

You can restore all tasks displayed in the Task pane before any filtering.

TO CLEAR THE FILTER FIELDS

1. In the Edit menu, select Clear Filters.

2. Click the Search button.

All unfiltered tasks should be restored to your display.

Arrow activating 

drop-down list
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REJECTING TASKS

If you performed the Get command on a task and now do not want to work on it, you can 
reject it. When a document is rejected, the ULTRA server makes it available to other users. 
You may need to discuss specific policies with regard to document rejection with the 
project's Language Manager before using this option.

TO REJECT A TASKS:

1. Connect to the Internet using your computer's usual method.

2. Connect to the ULTRA server. 

3. In the Task pane, select a task that is available on your desktop.

4. Click the Reject Selected Tasks button, or File> Reject Tasks.

5. The Reject Reason dialog box opens. 

6. From the drop down list in the Reject Reason dialog, select a reason for rejecting 
the document. 

7. Enter any comments you have in the Comment field.

8. Click the Reject button in the Reject Reason dialog box, or File>Reject Tasks.

The task is sent to ULTRA as a rejection with your reason and comments. To 
remove the task from your Task pane you must Delete it.

Comment field
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CHANGING A FILE TYPE

In some cases, it may become necessary for a Localization Engineer to change the file type 
(also known as the MIME type) of a task before submission. To check in a document with 
a changed file type extension (for example, “Document.html” is changed to 
“Document.rtf”), Document Manager must be informed of the change in order to 
recognize the new file name. This is accomplished through the use of the Change Type 
command. 

NOTE: Translators, Editors, and Proofreaders should not use the 
Change Type command unless specifically authorized to 
do so by a Language Manager.

The document with the changed file type must have the same name as the original 
document, with the exception of the file type extension. In addition, the new document 
must be saved in the same folder as the original document.

TO CHANGE A TASK’S FILE TYPE:

1. Get the task from ULTRA.

2. In the Task pane, select the task you want to change.

3. From the File menu, select Change Type.

The Change Task Type pane is displayed.

4. From the drop down list, select the file type you want the task changed to.

5. Click the Change button.

You should get a message reading “The [file type] file is present” at the bottom of the 
window (see illustration, below). If the message reads “The [file type] file is missing”, you 
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will need to check the document's file extension and location. Refer to the original 
document's path information to determine to correct file location.
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EXPORTING TRANSLATION MEMORY (TM)

You can use your team’s TRADOS-compatible translation memory in your translation 
projects. Document Manager allows you to bring the translation memory in through a 
simple procedure from the ULTRA server.

TO GET TRANSLATION MEMORY:

1. In the File menu, select Export TM from ULTRA.

The ULTRA TM Export to TRADOS window opens.

2. Select the Project name from the drop down list. This is the translation memory 
associated with a particular project on the ULTRA server.

3. Select the Target Language from the drop down list. This is the translation 
memory associated with a particular target language.

4. In the Export File field, select the file location and name you want your 
translation memory to be placed on your desktop.

5. In the Since date field, enter the date you want the translation memory you are 
getting from ULTRA to indicate.

6. Click Export to get the translation memory.

The TRADOS-compatible translation memory is retrieved from ULTRA to your 
local drive and is ready for you to use.
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DISCONNECTING FROM ULTRA

You can disconnect from ULTRA at any point and work offline using just ULTRA 
Desktop. Be sure that you have obtained all the necessary task that you need to work. 
Once you have done this, you also no longer need to be connected to the Internet.

TO DISCONNECT FROM ULTRA:

1. In the File menu, select Disconnect.

2. Begin selecting and opening tasks in the Tasks pane.
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Using Image Manager

Image Manager facilitates graphics localization. It provides a single source for viewing, 
assessing, transcribing, and translating graphics. It works with Document Manager to 
manage the graphics localization process.

In this chapter, the following topics are discussed:

• Understanding Image Manager

• The Image Manager window

• Column headers

• Creating GTX files

• Opening GTX files

• Assessing graphics with Image Manager

• Transcribing images with Image Manager

• Translating images using Image Manager

• Rejecting images with Image Manager

• Copying images associated with a GTX file

• Searching in Image Manager

• Generating Image Reports

• Saving as RTF

• Keyboard shortcuts
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UNDERSTANDING IMAGE MANAGER

Graphics localization is simplified using the Image Manager tool. Image Manager stores 
data in the GTX file. To use Image Manager a graphic or group of graphics must be 
associated with a GTX file. A GTX file is a graphics transcription file that is associated 
with one or more graphic images selected in the Task pane. Within Image Manager you 
are able to view graphics, transcribe the source content from each graphic, and translate 
the content of each graphic. The results of this work are stored in the GTX file and 
displayed in Image Manager.

During the image localization process a graphics file is submitted to ULTRA for 
assessment, transcription, and translation, all of which occurs using Image Manager. The 
image is then sent to a Graphics Engineer to be localized, which takes place outside of the 
Image Manager tool. 

Table 8: Image Manager roles details the roles and how each role can use Image Manager.

Table 8: Image Manager roles

Role Definition

Assessor Assesses the graphic for the next step in the workflow, and makes 

basic decisions on the graphic. For example, an assessor 

determines if a graphic is translatable, if it’s a repeat, if it’s an 

image fragment, if it’s a screen shot, an animated GIF, or if it is a 

complex graphic. An assessor can also create a GTX file from 

graphics selected in Document Manager’s Tasks pane.

Transcriber Creates a GTX file if it hasn’t already been created from graphics 

in the Document Manager’s Tasks pane. In Image Manager, 

transcribes the source text of the graphics, and adds any notes 

that may help the translator.

Translator Translates the transcribed text.

Graphics 

Engineer

Renders the new graphic with the translated text which is 

recorded in the GTX file and can be viewed in Image Manager.
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THE IMAGE MANAGER WINDOW

The Image Manager window is the central access point to the features available in the 
graphics localization process. Figure 5: Image Manager window, shows the main features.

Figure 5: Image Manager window

Column headers. Displays the name of each column.

Menus. Allows access to all of Image Manager’s features.

Toolbar. Quick access to Image Manager’s features.

Filter fields. A field or drop down list for specifying values to search for in the list of 
images.

eTranslate Iogo. Spins when connecting with the ULTRA server.

Document counter. Displays the number of graphics associated with the GTX file and 
how many are currently selected.

Content display pane. Displays a view of a GIF or a JPEG file.

Source pane. The field where the original text of the graphic is transcribed.

Toolbar

Menus

eTranslate logo

Filter fields

Source pane

Column headers

Content display pane Source Notes pane

Target Notes pane

Target pane

Document counter
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Source Notes pane. The field where any notes on the source transcription can be 
added.

Target pane. The field where the target language translation of the transcribed text is 
entered.

Target Notes pane. The field where any notes on the target translation are added.
52 ULTRA Desktop User’s Guide



USING IMAGE MANAGER

Column headers
COLUMN HEADERS

The column headers identify information displayed for each graphic within a GTX file. 
Figure 6: Image Manager column headers, shows the location of the column headers and 
what column headers are used.

Figure 6: Image Manager column headers

File. The actual file name of the image that was brought into the GTX file.

Word Count. The number of transcribed words in the each file.

Translatable. Displays True if the image is translatable, or False if it is not.

Image Fragment. Displays True if the graphic is an fragment of a another image, or 
False if it is not, and therefore translatable.

Screenshot. Displays True if the image is a screenshot, or False it is not.

Animated GIF. Displays True if the image is an animated GIF, or False if it is not.

Complex. Displays True if a image may take more time to render than a simple graphic.

Path. The source path location of the file on your desktop.

Column headers
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CREATING GTX FILES

To work in Image Manager you must select one or more graphics from Document 
Manager’s Tasks pane and associate them with a GTX file. The GTX file is the only file 
Image Manager will open. Figure 7: Selecting graphics for a GTX file demonstrates how 
selected graphic files in the Document Manger Task pane will appear in a newly created 
GTX file within Image Manager.

GTX files are created by ULTRA Desktop for use with Image Manager. When a new file is 
created it is saved in a temporary folder in your local File Path. 

TO CREATE A GTX FILE:

1. Get any graphics files you want in your GTX files from ULTRA.

2. In Document Manager, select graphics content from the Task pane.

Figure 7: Selecting graphics for a GTX file

3. From the File menu, select Assess/Transcribe Images.

The Save As dialog opens. 

4. Name the GTX file.

5. Click the Save As button to save the GTX file.

The newly created GTX file is now available to you from Document Manager’s 
Task pane and Image Manager is opened.

Document 

Manager Task 

pane

Image Manager 

window

Selected graphics
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OPENING GTX FILES

GTX files can only be opened through Document Manager’s Tasks pane. 

TO OPEN A GTX FILE:

1. In Document Manager’s Tasks pane, select the GTX file you want to open.

2. Double-click the file.

Image Manager opens and displays the contents of the file.

Once you have opened your GTX file you are ready to begin working.
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ASSESSING GRAPHICS WITH IMAGE MANAGER

As an assessor it is your responsibility to evaluate each graphic associated with a GTX file 
to determine whether and how it will be handled by the transcriber, translator, 
proofreader, and graphics engineer. 

TO ASSESS AN IMAGE:

1. With the GTX file open, select an image.

2. Determine if the image is translatable. Click in the graphic’s cell in the 
Translatable column to activate the drop down list, then select True or False.

If you select False, when you save the GTX file, Image Manager removes that 
graphic from the GTX file and reclassifies it in the Document Manager Task pane 
as Non-translatable. You must then Submit the task back to ULTRA as 
Non-translatable. It will not be transcribed, translated, or rendered.

3. Determine if the image is a repeat. Click in the graphic’s cell in the Repeat column 
and select True or False.

4. Determine if the image is an Image Fragment. Click in the graphic’s cell in the 
Image Fragment column and select True or False.

5. Determine if the image is a Screen Shot. Click in the graphic’s cell in the Screen 
Shot column and select True or False.
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6. Determine if the image is a Animated GIF. Click in the graphic’s cell in the 
Animated GIF column and select True or False.

7. Determine if the image is a Complex. Click in the graphic’s cell in the Complex 
column and select True or False.
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TRANSCRIBING IMAGES WITH IMAGE MANAGER

A GTX file contains data on one or more images files that need to be translated and 
localized. Within Image Manager you can see the image that needs to be translated. 

TO TRANSCRIBE A GRAPHIC

1. Open the GTX file in Image Manager by double-clicking on it in the Tasks pane.

2. Within Image Manager, select the image you want to transcribe.

The image of the image appears in the Content pane within Image Manager.

Figure 8: Image Manager window - transcribing

3. Transcribe the source language text to be translated from the graphic into the 
Source pane.

4. Add any related notes regarding the transcription into the Source Notes pane. 

Source Notes can be any information that needs to be related to the translator or 
graphics engineer, and be empty.

5. Save the GTX file when you have transcribed all graphics within the file by 
clicking the Save button, or File>Save.

Selected graphic
Selected graphic’s image

Source pane with source 

language transcribed
Source notes pane with notes 

on transcription, if any
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TRANSLATING IMAGES USING IMAGE MANAGER

A GTX file is ready to be translated once all images have been assessed and transcribed. A 
GTX file can contain data for more than one graphic that needs to be translated.

TO TRANSLATE A GTX FILE

1. Open the GTX file in Image Manager by double-clicking on it in the Tasks pane.

2. Image Manager opens and the contents of the GTX file are displayed.

3. Select the image you want to work on. 

4. Translate the text displayed in the Source pane into the Target pane.

NOTE: Read any notes in the Source Notes pane.

5. Add any notes regarding the translation to the Target Notes pane. 

Target Notes can be information that may help the proofreader or Graphics 
Engineer and can be empty.

6. Translate any remaining images.

7. Save the GTX file by clicking the Save button, or File>Save.
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REJECTING IMAGES WITH IMAGE MANAGER

It may be necessary to reject one or more images within a GTX file. Image Manager makes 
the process for rejecting images simple. 

TO REJECT AN IMAGE:

1. You must have a GTX file open and an image selected in Image Manager.

NOTE: You can reject more than one image at a time.

2. Click the Reject button, or File>Reject Images.

3. The Reject Reason window opens.

4. Select the reject reason from the drop down list.

5. Enter any comments regarding the reason for rejecting the image in the comments 
field.

6. Click the Reject button.

These images will be removed from the GTX file and Image Manager.

7. Finish your work and Submit the GTX file to ULTRA.

Reject reason drop 

down list

Comment field
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COPYING IMAGES ASSOCIATED WITH A GTX FILE

The GTX file contains information on each graphic associated with it. It does not contain 
images themselves. In the assess and transcribe step in the workflow, images are checked 
out for you and displayed in the Content pane. In the translation step, you may find it 
useful to view the images in the Content pane, therefore you must copy the images using 
Image Manager. 

TO COPY AN IMAGE:

1. Open the GTX file in Image Manager.

2. Select the graphics within the GTX file you want to copy to your desktop.

3. Click the Copy Images button, or File>Copy Images.

The image is copied to a temporary file in your document path and is now visible 
in Image Manager.
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Chapter  4
SEARCHING IN IMAGE MANAGER

A GTX file can have one or more images associated with it. You may need to search the list 
of graphics to access particular images quickly. Image Manager provides filter fields in 
each column to search for images. Depending upon the column, you can enter or select 
filters to define your search. When a large number of items are displayed, finding a 
graphic can be a challenge. By using the filters in each column header to narrow your 
search, you can display only the graphics which match the criteria you specify.

You can specify search criteria from any combination of fields. For example, entering 
“*.gif “in the File filter field and selecting True in the Animated GIF field refines the 
display to images with “.gif” as the file extension and Animated GIFs set to True.

You can select or enter information in as many filter fields as necessary. 

Text can be entered or pasted into the Path field in order to limit a search to document 
paths or filenames containing the specified text. Some things to keep in mind when 
defining Path text filters:

• Searches using the Path field are case-sensitive, so you must capitalize letters cor-
rectly in order to receive good results.

• The asterisk (*) must be used as a wildcard character when entering text. For 
example, entering “*memo*” in the Path field will show all documents with the 
text “memo” anywhere in its path or filename, regardless of what text is found 
before or after. If you do not use wildcards, you must enter the complete path or 
filename in order to get any search results.

TO ENTER TEXT IN THE PATH OR FILENAME FILTER

1. Enter text in the appropriate filter field. Add the asterisk (*) before and after an 
entry as a wildcard to search for results containing that word.

2. Click the Find Images button, or File>Find Images.

Document Manager displays the results of your search criteria.

TO SELECT CRITERIA FROM A DROP-DOWN LIST

1. Click on the filter for the column you want to sort.

2. Click on the arrow at the right side of the field to activate the pull-down list.

3. Scroll and click to select an item for the search.

4. Click the Find Images button, or File>Find Images.

Text filter field

Filter drop down list
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Numerical values can be typed or pasted into the Word fields. The asterisk (*) wildcard 
character may not be used in the Word field. A search based on a specified word count 
will return only those documents with exactly the word count entered in the field.

ENTERING NUMBERS WORD COUNT FILTER

1. Enter numbers in with the Word Count filter fields.

2. Click the Find Images button, or File>Find Images.

Image Manager only returns results with identical matches to the numbers you 
entered.

TO CLEAR THE FILTER FIELDS

1. In the Edit menu, select Clear Filters.

2. Click the Find Images button.

All unfiltered tasks should be restored to your display.
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Chapter  4
GENERATING IMAGE REPORTS

Image Manager can display a report on a GTX file that contains summary information on 
the assessment and transcription of the images. Figure 9: Image Report shows the 
information generated in the report.

Figure 9: Image Report

TO RUN AN IMAGE REPORT

1. Open the GTX file you want to run a report on in Image Manager.

2. In Image Manager’s File menu, select Image Report.

3. The Image Report window is displayed.

To print the Image Report, see Saving As RTF.
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SAVING AS RTF

The Save As RTF command creates a tabular report of the GTX file. Table 9: RTF file 
information details the information in the RTF file.

The Save As RTF command is useful to graphics engineers during the render step of the 
workflow when you may be working on a system that is independent of the ULTRA 
Desktop application. This command creates a RTF file with information that can be 
printed or viewed with Microsoft Word.

TO SAVE AS RTF:

1. Open the GTX file in Image Manager.

2. In the File menu, select Save As RTF.

Image Manager saves the file in the Temporary folder within your Document File 
Path.

Table 9: RTF file information

Column Header Definition

Path Name The path name of each graphic within the GTX file.

File Name The file name of each graphic in the GTX file. 

File Type The MIME type of file of a particular graphic with the 

GTX file.

Localizable Displays whether or not a graphic is localizable.

Word Count Displays the word count of the translated source 

language.

Source The transcribed source text of the graphic.

Target The translated text of the graphic.

Art Info Consolidated information indicating if a graphic is an 

Image Fragment, a Screen Shot, an Animated GIF, or 

Complex.

Source Notes Any notes the transcriber added.

Target Notes Any notes the translator added.
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Chapter  4
KEYBOARD SHORTCUTS

Image Manager provides keyboard shortcuts for some frequently used navigation 
commands. 

Table 10: Image Manager keyboard shortcuts lists the command shortcut combinations 
available and their definitions.

Table 10: Image Manager keyboard shortcuts

Keyboard shortcut Definition

ALT+x Moves the selection to the next row.

ALT+z Moves the curser to the previous row.

ALT+n Changes the selected graphic to (not translatable) False.

ALT+t Changes the selected graphic to (translatable) True.

ALT+i Moves focus to images table.

ALT+r Moves the cursor to the Source or Target field, as 

applicable.

ALT+o Moves the cursor to the Source Notes or Target Notes 

field, as applicable.

CTRL+x Cuts selected text.

CTRL+c Copies selected text.

CTRL+v Pastes text.
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Other Tools and

ULTRA Desktop

To work with TRADOS files and other applications you need to have the appropriate tools 
installed on your system. For example, you may use Adobe Photoshop for JPEG images 
and Adobe PageMaker for desktop publishing files. Documents can be obtained and 
submitted regardless of file type, provided they always remain in their original file 
locations.

To have Microsoft Word open with TRADOS-compatible RTF documents from the 
Document Manager window, for example, your computer's operating system must 
associate this file type with Microsoft Word.

This chapter contains the following sections:

• Working on a TRADOS RTF file overview

• Using other tools overview
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Chapter  5
WORKING ON A TRADOS RTF FILE OVERVIEW

You must launch the TRADOS Translator's Workbench application prior to opening a 
TRADOS-compatible RTF document from Document Manager. Then, if the file type is 
properly associated with Microsoft Word, the document opens in Microsoft 
Word/TRADOS.

This section is a quick overview of how simple it is to work on TRADOS-compatible RTF 
files with the ULTRA Desktop application. It takes you through the steps necessary to get 
your work completed and submitted using ULTRA Desktop and Microsoft 
Word/TRADOS.

TO WORK ON A TRADOS RTF FILE:

1. Launch ULTRA Desktop and connect to ULTRA.

2. Get any tasks from the Document Manager Task pane. A document icon 
appears next to the task once it is on your desktop.

3. Disconnect from ULTRA to begin your work offline.

4. In the Tasks pane, double-click on the TRADOS-compatible file you want to work 
on. If you do not want to work on the file, you can Reject it.

5. Your file opens in Microsoft Word/TRADOS.

6. Begin working on your file.

7. Save the file once you have completed your work.

NOTE: Do not change the name of a document or move a 
document to a different location. Document Manager 
looks for document files with their original names, in 
their original locations. Doing so makes it impossible to 
check-in the most recent version of the document. The 
only exception to this rule applies to Localization 
Engineers who must change the file type of a document 
as part of the localization process; in such cases, the 
Change Type command must be used.

8. Connect to ULTRA.

9. Submit the file back to ULTRA.
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USING OTHER TOOLS OVERVIEW

This section provides a quick overview of how simple it is to work on files associated with 
other applications with the ULTRA Desktop application. It takes you through the steps 
necessary to get your work completed and submitted using ULTRA Desktop. In order to 
work on a file associated with a particular application, for example, Adobe Photoshop, 
you must have that program installed on your desktop.

TO WORK ON A FILE USING ANOTHER APPLICATION:

1. Launch ULTRA Desktop and connect to ULTRA.

2. Get any tasks from the Document Manager Task pane. A document icon 
appears next to the task once it is on your desktop.

3. Disconnect from ULTRA to begin your work offline.

4. In the Tasks pane, double-click on the file you want to work on. If you do not 
want to work on the file, you can Reject it.

5. Your file opens in the application it is associated with.

6. Begin working on your file.

7. Save the file once you have completed your work.

NOTE: Do not change the name of a document or move a 
document to a different location. Document Manager 
looks for document files with their original names, in 
their original locations. Doing so makes it impossible to 
check-in the most recent version of the document. The 
only exception to this rule applies to Localization 
Engineers who must change the file type of a document 
as part of the localization process; in such cases, the 
Change Type command must be used.

8. Connect to ULTRA.

9. Submit the file back to ULTRA.
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